Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

In this Discussion

Security Warning Message
  • Badger
    Posts: 656
    Every time I try to access the General Forum, or any post there, I get a Security Warning message, which reads:

    Do you want to view only the webpage content that was delivered securely?

    This webpage contains content that will not be delivered using a secure HTTPS connection, which could compromise the security of the entire webpage.

    Does anybody else get this message? This started late last night, and turning off and restarting the computer doesn't correct the problem.

    Does Support know how to fix this?
  • RdrRdr
    Posts: 32
    Nope, not getting it.:confused:
  • rookrook
    Posts: 1,604
    Ditto Nope.

    Sounds like a client browser issue.

    I've never encountered a secure page on the Aneros website and tend to be a rather curious snoop. Unlike other sites, Our login's and passwords are passed in the clear, sans encryption..

    Perhaps though Aneros has some secure pages on the website for "superusers" or development and your browser accidentally (typo ?) picked up on one of those and stuffed it into history.

    Try the usual fixes ... clear the cache and all history. clear cookies. If you're using I.E. check the settings on Internet zone security and parental controls -- set those to defaults (middle of the range choices)

    If that doesn't clear it, clean the machine -- you may have a "helper" application that's messing with you. (Corporate laptop ??)

    Old quote, "Don't sweat this -- it isn't Paranoia --- people are really out to get you!" : lol :

    You might also consider using Google's Chrome Browser (free download). It has an "Incognito" mode that can isolate your browsing from history and caching.

    hth ... rook
  • I use chrome and it rocks.
  • valliant
    Posts: 120
    I have the same problem,the link starts with https instead of just http.
  • ME TOO!
    SAME PROBLEM!
    Starts with https instead of just http.........
  • [QUOTE=rook;90335]Sounds like a client browser issue.

    Old quote, "Don't sweat this -- it isn't Paranoia --- people are really out to get you!" : lol :

    To me, it looks like the link to the forum from the main Aneros page has been changed to https. Since I usually visit the community and forum through a bookmark (http) I have not noticed this until I used another computer to get here. Both ways work, one gives a warning.
  • rookrook
    Posts: 1,604
    Hey Pepnautic and Badger,
    Agree -- tried that link and saw the 'https'

    On this machine, the warning is disabled.
  • Badger
    Posts: 656
    How do you disable the warning? It's very annoying! Plus, I'm accessing this website through Favorites (bookmark) already, but it still does it.
  • Love_isLove_is
    Posts: 1,672
    This has got to be a recent change here in the Aneros forums. I only have just noticed this today. Firefox 3.6.8 only gives me a mild warning in the bottom right status bar of a padlock with an exclamation over it. For those of you with annoying warning messages, keep in mind this is designed to alert you to not submitting information to a partially encrypted web site, such as when making a purchase on web page. In that circumstance, you would absolutely want that warning message to keep you from doing that! Otherwise you can remove these warnings, but I don't recommend it for non-technically savy computer users that don't understand the implications of doing so. It would be best to wait for Aneros to correct the forum changes they have made. Otherwise you can generally find these warning notification settings in the browser settings.

    I'm not sure what the Aneros IT people's intent is to partially encrypt the forum access. My understanding is you either completely encrypt, or not all. As anything in between will not be secure. Perhaps this would be a good time for Aneros support to speak up and explain themselves.

    Love_is
  • rookrook
    Posts: 1,604
    [QUOTE=Badger;90363]How do you disable the warning? It's very annoying! Plus, I'm accessing this website through Favorites (bookmark) already, but it still does it.

    I examined four different login opportunities on the Aneros website and NONE employ encryption -- so there's no reason to enter the site on the home page save for your handle being linked to prior purchases. And, that thinking is a bit of a 'reach.'

    Assuming (with all the attendant hazards) that there's method or intent to the current design, the easy way out is to change one's bookmark to: == www.aneros.com/forum == Save that to Favorites.

    The Forum page is less complex and loads a lot faster than does the home page. This gives you a straight shot to Forums and a very accessible menu to navigate to Mail, Chat, Blogs & Wiki. Much easier to use than the Home page.

    If, you wish to ignore Love_is' cautionary note, and desire to disable the warning (for all situations) and are using Internat Explorer do the followng (based on IE ver 6.x):

    Click on Tools > Options and choose the "Advanced" tab. Scroll down to the security section where you'll find the "Warn when changing from a secure to non-secure page" then remove the checkmark to the left of that statement. Then, clock on "OK" and close I.E.
  • Badger
    Posts: 656
    rook;

    It's already unchecked. I'm beginning to wonder if it has something to do with ZoneAlarm's Firewall, which is beginning to be a pain in the ass, and not in a good way.

    What next?
  • Maximus
    Posts: 62
    As others have said, bookmark the forums as http://www.aneros.com/forum

    The warning message is displayed because https: tells your browser to use encryption when loading the page and certain content on the page is not specified as coming from an encrypted connection. In this forum's case, the images that make up the background are being served from a non-encrypted source. The reason this is a warning is because the browser cannot reliably determine whether data you submit back to the website is always going to be encrypted, thus the page is not secure.

    Nothing to worry about unless you are going to be submitting sensitive data like credit card numbers, etc. The warning is there for a purpose. Do not turn it off unless you're not concerned about secure internet transactions.
  • Love_isLove_is
    Posts: 1,672
    Looks like it's been corrected. The forums no longer default to https for me in addition to no longer showing a partially encrypted page warning in the status bar. It would have been nice to have gotten some feedback from Aneros tech support. But as long as it works correctly that's all that matters.

    Love_is
  • Badger
    Posts: 656
    Yep, mine suddenly started working recently as well. Don't know what fixed it, though.
  • rookrook
    Posts: 1,604
    Finally got around to setting all the options in Firefox 3.6.8. This may be 'old hat' to many here but handy info for the more paranoid in the crowd.

    Happy to see that Firefox now has an option to start all sessions in the "Private Browsing" mode. This resembles the "Incognito Window" in Chrome and, without the extra keystrokes.