Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

In this Discussion

Is anyone having trouble accessing Xtube?
  • Is anyone having trouble accessing Xtube? http://www.xtube.com All I get is a referral site from there on both my computers. Some friends of mine are still able to access it though. I can go on any other site. So does anyone know what's going on or if the same thing is happening to them? Has Xtube closed its site forever?
  • No problem getting on X-Tube here. Might be a router problem with your service.
  • Love_isLove_is
    Posts: 1,672
    No problems either here equalityboy81.

    Remember, if your horny and need yank while watching Internet porn. There is always other sites you can visit! ;) :lol:

    Love_is
  • Now the page cannot be displayed. Other sites can though. I just want to know why it cannot be displayed on either one of my computers but can on everyone else's.

    Can you all click on my profile link and see if I still have a profile? Xtube has been weird lately. Weeks ago they removed all the photos of a photo set of me and my friend using the Fleshlight but no other photos sets. That set was on there for over six months and didn't violate any rules or copyright laws. No explanation was given to why they were removed.

    Here is my profile link:

    http://www.xtube.com/community/profile.php?user=equalityboy81

    I don't believe I've done anything to violate any rules but you think it that were the case they'd delete or suspend my account and give me some type of notice. You wouldn't think they'd go as far as ban people's ISPs. You don't think that is the case do you? I want to go on Xtube and see Arctic Wolves' videos.
  • alvalv
    Posts: 179
    equalityboy81 that is a nice ass you have :D
  • cyrez said:

    Yesterday night they were down a few hours, and i got redirected to another site, and i was wondering what the hell was happening, but today everything seems ok, hope you'll manage to get them working



    It was a different site last night and then in the morning. Same thing happened to me.
  • alv said:

    equalityboy81 that is a nice ass you have :D



    Thank you. I like the underwear pic icon you have. It's pretty cool!
  • alvalv
    Posts: 179

    I like the underwear pic icon you have. It's pretty cool!

    Used my JVC HD camcorder in continuous still image mode, about 3-4 frames a second, one soon gets 100+ photos and then one can always find one shot that stands out. This is one such shot suitably cropped for an original avatar.

    You may discover it on two other forums (and on xtube), a prize is offered for the first one who finds the forum where I use this avatar - and alv is not my user-name on those two sites - happy hunting
  • Love_isLove_is
    Posts: 1,672
    Hello equalityboy81, :)

    There is a number of reasons for these things to occur. They could have had problems with their domain name registrar, as far as forgetting to re-new to the domain name, or maybe the IP address it points to was hacked to a different one. They may be experiencing a denial of service attack, which would make the web site either not accessible, or really slow. They can't afford the bandwidth they really need to effectively service their audience, which would also make the web site slow and possibly inaccessible at times. The web servers are somehow max'd out either through too many legitimate requests, updates occuring , database functions, or maintenance routines, that would also again either make pages slow to come up, or make the web site inaccessible.

    Your profile does show for me. But it took a very long time to do so. Perhaps there is a forum or support section on xtube.com that you can contact them to ask about these problems?

    Love_is