Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In with Google

In this Discussion

Can too much lube...
  • cause this thing to not work properly? Here's the problem. I've used the Aneros three times to date. All three times I've had little or no feeling around my prostate for the hour that I had it inserted. I've also had very, very little pre-cum during all three sessions. When I move to different positions, I find that this device sometimes slides to far down with the lube that I'm using, and once it slid right back out, after being fully inserted and relaxing my muscles. I've never been into anal sex and I'm a healthy 30 year old, but I was thinking that I might be using too much lube, which in turn, has caused the Aneros to slide back out. I use KY to lube up, and then apply Liquid Silk to the Aneros. Any thoughts?
  • B MayfieldB Mayfield
    Posts: 2,077
    Seems like two issues here, first I am curious, are you using an SGX or an MGX ? Your question regarding the lack of prostate contact is what leads me to wonder. The SGX (the smaller/shorter of the two units) affords significantly less contact than does the MGX. If you are using the MGX, my next question would be, are you completely inserting the unit ? If so and you are still not getting adequate prostate contact, you might want to try some different positions, i.e. on all fours, on your side (I prefer left) with knees pulled up towards your chest, squatting, and lastly (one of my favorites) kneeling, with your knees on the floor and your head and chest lying on a bed. If you're still having difficulty, you may want to consider obtaining an old style MGX, it has knobs on the end of it that may give that little extra that you're looking for.

    With respect to the amount of lubrication that you are using, it sounds as if you could get by with far less ( and example of too much of a good thing I would guess). It should be noted that the manufacturer and numerous users (including myself) have long suggested using copious of amounts of lubrication. The reason for this have been two-fold: first, to make insertion and usage of the Aneros more comfortable, particularly for those who have little experience with anal play. Many who are new to this kind of activity may be nervous initially and are as a consequence a little bit tight, anally. Being highly lubricated facilitates insertion no doubt about it. Furthermore, lubrication reduces friction to a minimum such that a newbie is better able to become accustomed to the sensation of the Aneros moving in and out. The second reason relates to creating the optimum mobility of the device in the anus/rectum. In this way the Aneros becomes extremely responsive to even the smallest contraction.

    This having been said, my thinking has evolved somewhat when it comes to the subject of lubrication. Whereas I still believe that a certain amount is essential to the proper use of the Aneros, the amount may be far less than has been suggested in the past, (in particular, for the more experienced user). Specifically, in my own case where I used to ordinarily pre-lubricate with KY liquid (or some thinner glycerin based product) prior to introducing a KY jelly covered Aneros, I rarely do this now. I've found the pre-lubrication to be unnecessary.

    In your case, where anal tension does not appear to be an issue, I would suggest dispensing with the KY Silk, you don't need it. It sounds as if you have too much mobility going on with the extra lubrication. Remember, a certain amount of friction is good! Try sticking with the KY jelly alone, and see how you do with that.

    Keep at it and enjoy!

    B Mayfield
  • Thanks for the reply. I have the MGX, and yes, I have fully inserted it all the way in. It just seems to slide in and out to easy, and that's why I think I might of been using too much lube. I'll try using less the next time, and I'm hoping that using too much lube might of been the problem. I'll keep you informed as I go.