Prostate Massagers Sex Toys for Woman Aneros Accessories Sex Toys for Couples Special Offers Sex Toys for Men Lubricants Masturbators
Aneros Blogs > skeptimo's Blog > View Entry

Nothing!!!!

I just got my Helix today and...nothing. I can feel it inside of me but there is no pleasure at all. I removed it, relubed and inserted. Again nothing. Tried it a third time and this time it actually hurt. I'm using water based lube (Wet). What am I doing wrong?

Reader Comments

Posted on 2007-01-24 08:48:14 by charlie

Hello skeptimo, and welcome to the blogs.

I suspect that you are not sufficiently relaxed and that is why you experienced discomfort. You have to let go of any negative thoughts and taboos regarding anal penetration before your body will relax and accept the pleasures that are ahead of you.

Maybe a semi-strenuous workout followed by a long hot shower or soak in the tub will help you relax. Follow that by preparing a warm, comfortable, and private place for your session. Take your time and don't rush things. Lower your expectations. This is a journey, and the guy who orgasms his first time is an exception rather than the rule.

Do not insert the aneros until you have followed the recommended breathing exercises. Be sure that you apply a liberal amount of lube to the unit, too. Don't start any contractions until your body is relaxed. Once you start your contractions, be very gentle. You really don't need to push very hard.

I suspect your disappointing first experience was more mental than physical. If I'm wrong, however, and you still have discomfort, stop. The experience should not be uncomfortable. Hope this advice is helpful. Take care and good luck,

Charlie

Posted on 2007-01-24 16:37:16 by skeptimo

Thanks for the comments. I'll have to give it another try however I find that the Aneros itself is unnaturally hard and this is the cause of my distress. I am no stranger to anal play and I have yet to encounter anything this hard.

Posted on 2007-01-24 21:13:48 by skeptimo

Another attempt tonight. Again nothing but pain from the device digging into my perineum. The discomfort is so intense I can not even achieve an erection. This is the worst product I have ever used.

Posted on 2007-01-25 04:54:08 by Buster

Hey skeptimo,

There have been others that have been bothered with the tab digging in. There are threads in the forum about it. The one that I remember right off the top of my head that I thought was interesting had to do with getting a ping pong ball and cutting a hole in it and putting the tab through the hole so the only material touching your skin is the other side of the ball and that should spread out the area a bit that is under pressure. It is certainly a cheap potential fix. Dont give up. These things are remarkable when everything comes together.

Buster

Posted on 2007-01-27 20:06:57 by skeptimo

I changed lube and that really helped. Water based Wet just didn't allow the Helix to move enough so I tried ID Millennium and OMG...it really works!!! Damn! I also didn't insert the Helix all the way in after reading the tip on this site. There is a learning curve with this thing but once you find what works for you're all set for hours of fun.

Posted on 2007-01-28 07:54:10 by Buster

Hi skeptimo,

That sounds like a significant step you had. I also had a step similar to that within the first couple of months of my journey. It is interesting to note that at that point, the lube I used was such a large factor, and now, I barely use any lube at all. I find now that a liberal coating of vaseline is all that is needed. What that shows you is that what helps you along changes as you progress.

Keep going with your experimenting. Also, what others are doing and trying can be very helpful as well.

Take care.

Buster

Posted on 2007-01-29 14:23:33 by charlie

Good news skeptimo!
Keep at it and let us know where your journey takes you.
Best wishes,
Charlie